In this tutorial we will take a look how you can create an
Etherchannel link over 802.1Q tunneling. If you have no idea how 802.1Q
tunneling works, it’s best to read my previous tutorial first that
covers the basics of 802.1Q tunneling.
Here’s the topology that I will use:
SW2 and SW3 are the service provider network. SW1 and SW4 belong to the customer and present two different sites. The idea is that we want to create an Etherchannel between SW1 and SW4 over the service provider network. First we will configure the trunk between SW2 and SW3:
If we would use a single transit VLAN for all traffic on the FastEthernet 0/23 and 24 interfaces then we run into issues with our Etherchannel because FastEthernet 0/23 could talk to 0/24 or vice versa.
Here’s the configuration for SW2:
Here’s the topology that I will use:
SW2 and SW3 are the service provider network. SW1 and SW4 belong to the customer and present two different sites. The idea is that we want to create an Etherchannel between SW1 and SW4 over the service provider network. First we will configure the trunk between SW2 and SW3:
SW2(config)#interface fastEthernet 0/21
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk
SW3(config)#interface fastEthernet 0/21
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk
Our next move is to configure the interfaces pointing towards the
customer switches. To “simulate” that our FastEthernet 0/23 +/24
interfaces on SW1 and SW4 are directly connected to each other we have
to use a separate “transit” VLAN for each interface pair. Traffic on the
FastEthernet 0/23 interface will flow in service provider VLAN 100 and
traffic for FastEthernet 0/24 will use VLAN 200. Take a look at the
picture below to visualize this:If we would use a single transit VLAN for all traffic on the FastEthernet 0/23 and 24 interfaces then we run into issues with our Etherchannel because FastEthernet 0/23 could talk to 0/24 or vice versa.
Here’s the configuration for SW2:
SW2(config)#interface fastEthernet 0/23
SW2(config-if)#switchport access vlan 100
SW2(config-if)#switchport mode dot1q-tunnel
SW2(config-if)#l2protocol-tunnel point-to-point pagp
SW2(config)#interface fastEthernet 0/24
SW2(config-if)#switchport access vlan 200
SW2(config-if)#switchport mode dot1q-tunnel
SW2(config-if)#l2protocol-tunnel point-to-point pagp
The magic bullet that makes the etherchannel possible is the l2protocol-tunnel command and specifying PAgP or LACP. The configuration for SW3 is similar:SW3(config)#interface fastEthernet 1/0/23
SW3(config-if)#switchport access vlan 100
SW3(config-if)#switchport mode dot1q-tunnel
SW3(config-if)#l2protocol-tunnel point-to-point pagp
SW3(config)#interface fastEthernet 0/24
SW3(config-if)#switchport access vlan 200
SW3(config-if)#switchport mode dot1q-tunnel
SW3(config-if)#l2protocol-tunnel point-to-point pagp
Our service provider switches are now ready, the configuration on the
customer switches is just a regular Etherchannel configuration:SW1(config)#interface range fastEthernet 0/23 - 24
SW1(config-if-range)#switchport trunk encapsulation dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#channel-group 14 mode desirable
Creating a port-channel interface Port-channel 14
And something similar for SW4:SW4(config)#interface range fastEthernet 0/23 - 24
SW4(config-if-range)#switchport trunk encapsulation dot1q
SW4(config-if-range)#switchport mode trunk
SW4(config-if-range)#channel-group 14 mode desirable
Creating a port-channel interface Port-channel 14
If everything went OK you should see a message on the console that
the port channel interface is “up”. We can also verify it with the show
etherchannel command:SW1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
14 Po14(SU) PAgP Fa0/23(P) Fa0/24(P)
SW4#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
14 Po14(SU) PAgP Fa0/23(P) Fa0/24(P)
Aucun commentaire :
Enregistrer un commentaire